Python中使用numpy和pandas时报错:RuntimeError: The current Numpy installation ('...\\venv\\lib\\site-packages\\numpy\\__init__.py') fails to pass a sanity check due to a bug in the windows runtime。本文主要介绍Python中解决此异常错误方法。

1、使用python3.9和numpy1.19.4时会发生此错误

解决方法:卸载numpy1.19.4并安装1.19.3, 即可解决此问题。

pip uninstall numpy
pip install numpy == 1.19.3

2、使用Python 3.7报错

pip install numpy==1.19.3

3、异常错误问题原因

numpy 1.19.4所有Python版本都无法执行的错误。使用以前的版本来解决该问题,因此通过终端:

pip install numpy==1.19.3

4、pip安装及使用

1) linux上安装pip

查看 python版本:

python --version

通过以下命令来判断是否已安装pip --version。如果没有,使用以下方法来安装:

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py   # 下载安装脚本
sudo python get-pip.py # python2 运行安装脚本

用想要使用的版本 Python运行安装脚本,pip就被关联到哪个版本,如果是 Python3 则执行以下命令:

sudo python3 get-pip.py    # 运行安装脚本。

注意:一般情况 pip 对应的是 Python 2.7,pip3 对应的是 Python 3.x。

部分 Linux 发行版可直接用包管理器安装 pip,如 Debian 和 Ubuntu:

sudo apt-get install python-pip

2) windows上安装pip

相关文档Python 在Windows、Mac和Linux上安装pip的方法

3) pip 最常用命令

显示版本和路径

pip --version

获取帮助

pip --help

升级 pip

pip install -U pip

如果这个升级命令出现问题 ,可以使用以下命令:

sudo easy_install --upgrade pip

安装包

pip install SomePackage              # 最新版本 
pip install SomePackage==1.0.4 # 指定版本 
pip install 'SomePackage>=1.0.4' # 最小版本

比如我要安装 Django。用以下的一条命令就可以,方便快捷。

pip install Django==1.7

升级包

pip install --upgrade SomePackage

升级指定的包,通过使用==, >=, <=, >, < 来指定一个版本号。

卸载包

pip uninstall SomePackage

搜索包

pip search SomePackage

显示安装包信息

pip show 

查看指定包的详细信息

pip show -f SomePackage

列出已安装的包

pip list

查看可升级的包

pip list -o

注意事项:

如果 Python2 和 Python3 同时有 pip,则使用方法如下:

Python2:

python2 -m pip install XXX

Python3:

python3 -m pip install XXX